Dit is een site voor studenten van de Open Universiteit. Voordat je een vraag kunt stellen moet je even een account aanmaken (dit systeem is niet gekoppeld aan je OU studentnummer en wachtwoord).

Welkom bij het vraag- en antwoord systeem van de onderzoeks-practica van de studie psychologie bij de Open Universiteit.

Houd er, als je een vraag stelt, rekening mee dat je de richtlijnen volgt!

onduidelijkheden cursus PB0202 + niet werkende spss24

0 leuk 0 niet-leuks

Beste Gjalt-Jorn,

Allereerste merk ik op dat je niet ingaat op de punten die ik benoem over dit vak. Zou dat toch nog kunnen doen? 

En zoals ik al eerder heb geschreven, heb ik geen goede start gemaakt met Oupsy doordat naar mijn initiele vraag is verdwenen. Vandaar deze vragen via email.

Verder staat er nergens in het werkboek vermeldt hoe ik SPSS 24 geinstalleerd krijg op mijn MacBook 2016 (Sierra), want SPSS 22 werkt uberhaupt niet op deze OSX versie. Daarbij maakt het verder niet uit of ik de software eerder of later installeer, als het niet werkt dan werkt het niet. Nu ben ik daar in ieder geval al 2-3 weker eerder achter. Ik heb inderdaad over het stuk dat ik de 'verleng'versie van SPSS moest hebben heen gelezen. 

Begrijp ik nu goed dat er in dit vak dezelfde uitgebreide instructies voor R als voor SPSS beschikbaar zullen zijn? Ik kreeg tot nu toe het idee dat ik hiervoor specifiek SPSS geacht werd te gebruiken ook i.v.m. latere vakken & onderzoek doen. En dan vraag ik me af waarom er wordt gesuggereerd om dit SPSS pakket te kopen. 

Als laatste nodig ik je graag zelf uit om een keer contact met IBM op te nemen, dat is de meest kansloze exercitie die ik ooit ondernomen heb. Zelfs mijn vriend, die heel handig is met computers, programmeren en software (die krijgt SPSS ook niet werkent), lukt het niet om in contact te komen met IBM over dit probleem.

Samenvattend heb ik de volgende vragen:

  • Zou je in kunnen gaan op mijn eerdere punten?
  • Wat is het aanbevolen software pakket voor dit vak?

Het moge duidelijk zijn dat ik niet blij ben met hoe de communicatie en begeleiding tot nu toe verloopt, dat heeft er nu voornamelijk mee te maken dat ik al 2-3 weken tervergeefs een software pakket aan de praat probeer te krijgen (=verloren tijd) en in contact komen met jullie/de docent(en) vind ik moeizaam (vraag verdwenen Oupsy).

Graag lees ik je reactie op bovenstaande.

Groeten,

gevraagd 23 mei 2017 in SPSS door M.H. (170 punten)

2 Antwoorden

0 leuk 0 niet-leuks
Jammer genoeg heb ik geen PC die OSX draait, en ben ik niet bekend met hoe SPSS 'onder de motorkap' werkt, dus ik kan niet vaststellen wat er fout gaat als SPSS het ergens niet doet.

Er lijkt ofwel iets mis te zijn met je systeem, of met de versie van SPSS die je hebt gedownload.

Als IBM niet reageert kun je ook proberen contact op te nemen met SurfSpot (i.e. de verkoper). Zij kunnen je wellicht aan andere kanalen helpen om contact op te nemen met IBM.

Er is geen aanbevolen softwarepakket voor dit vak. Je kunt kiezen welke je wil gebruiken. R is een stuk krachtiger en veelzijdiger dan SPSS, en bovendien gratis. Het voordeel is dus dat je er over blijft beschikken na je afstuderen: je bent niet afhankelijk van de student-licentie voor SPSS. SPSS kost normaal veel meer (honderden, misschien wel duizenden euro's).

De vervolgcursus, Experimenteel Onderzoek, is echter nog niet omgezet naar R, en wordt nog alleen met SPSS aangeboden. Het doel is om deze cursus rond de zomer om te zetten, maar dat zou natuurlijk vertraging op kunnen lopen. Je neemt hier dus een zeker risico. Tegelijkertijd zijn er een hoop studenten die zelf wel door zijn gegaan met R, en dus kunnen helpen mocht je 'te vroeg' bij Experimenteel Onderzoek belanden.

De reden dat er geen enkel softwarepakket wordt aanbevolen is overigens wat ingewikkeld. SPSS was lange tijd de standaard voor statistische analyses, maar om de een of andere reden zitten er een hoop problemen in SPSS die ze er niet uithalen, of beter gezegd, ontbreekt er veel functionaliteit die ze niet toevoegen, en dit is al decennia het geval. R is snel bezig de nieuwe standaard te worden, maar al het cursusmateriaal is nog voor SPSS. Verder blijkt dat blinde en slechtziende studenten niet goed met SPSS kunnen werken (hun schermlezers kunnen R wel goed lezen, maar SPSS niet). Een andere ontwikkeling is dat de bewustwording dat het belangrijk is om al je analyses in analysescripts te verwerken, maakt dat het verschil tussen SPSS en R verdwijnt. SPSS kon vroeger met de menu's worden gebruikt, maar dat is tegenwoordig niet meer goed te combineren met ethisch/integer onderzoek, omdat de analyses dan niet repliceerbaar zijn. Omdat analysescripts een noodzakelijk onderdeel zijn, is SPSS opeens onhandiger geworden dan R, omdat de scripttaal van SPSS ('syntax') erg weinig intuitief is.

Kortom, om allerlei goede redenen is er een soort overgang in de psychologische wetenschap van SPSS naar R. Deze overgang is ook merkbaar in het curriculum, en om die reden kun je dus zelf kiezen welke software je wil gebruiken.

De problemen die SPSS geeft bij installatie, zoals bij jou, zijn overigens ook een reden dat we R in parallel aanbieden - op die manier hoef je geen vertraging op te lopen.

Welke software je gebruikt maakt immers voor je begrip van de stof weinig uit. Steekproevenverdelingen zijn niet makkelijker te begrijpen in R dan in SPSS, of andersom.

Je kunt dus zelf kiezen welke software je het liefste gebruikt.

Ik heb kennelijk andere vragen gemist; mijn excuses. Zou je deze ook in dit systeem kunnen stellen (met een aparte vraag per vraag, zie de instructies op http://oupsy.nl/help/ask)?
beantwoord 23 mei 2017 door gjp (64,270 punten)
0 leuk 0 niet-leuks
Op jouw systeem (MacBook met Sierra) kan je versie 22 van SPSS niet installeren, versie 24 wel. Hier heeft eerder (van mij) al een opmerking over op OUpsy gestaan. Bij surfspot staat genoemd dat versie 22 maar tot OSX 10.9 ondersteund wordt. Voor macOS 10.12 zul je echt versie 24 moeten aanschaffen.
beantwoord 23 mei 2017 door Reinout Vrijhoef (7,480 punten)
Dankjewel Reinout Vrijhoef voor je reactie. Aangezien mijn eerdere vraag verdwenen is op Oupsy, heb ik per email contact gezocht met Gjalt-Jorn en een andere docent.  In die mail heb ik al aangegeven dat ik dus eerst SPSS 22 heb aangeschaft, wat dus niet werkte, en daarna ook SPSS 24 heb aangeschaft. Deze crashed zodra ik het programma probeer op te starten.

Weet jij daar een oplossing voor?
Dat is zo niet te zeggen. Krijg je een bepaalde foutmelding?

Edit: bij een google zoektocht op "spss 24 crash sierra" kwam ik de volgende link tegen: https://developer.ibm.com/answers/questions/327399/spss-24-freezes-on-on-sierra.html. Misschien is een herinstallatie een optie?
Ik heb nooit foutmeldingen gekregen, het programma crashte direct. Omdat ik SPSS niet aan de praat kreeg ben ik (ook) met R in de weer gegaan. Daar liep ik juist weer tegen problemen met specifieke pakketen aan. Toen ik tijdens een van de handelingen het bestand Statistiek_Angst.sav wilde openen in R, opende deze prompt in SPSS 24. Mijn verbazing was groot en 'durf' het programma dan ook niet meer te sluiten nu. Voor nu kan ik dus eindelijk verder met de opdrachten.

Bedankt in ieder geval voor je bereidheid om mee te denken.

Je kunt een .sav bestand niet rechtstreeks in R openen. Deze zul je moeten importeren met bijvoorbeeld de functie getData() uit het userfriendlyscience package.

...